summary refs log tree commit diff
path: root/gnu/packages/pcre.scm
diff options
context:
space:
mode:
authorJean-Baptiste Volatier <jbv@pm.me>2021-07-03 17:41:39 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-07-28 16:05:31 +0300
commit7db9573e862ccbb44221d3e4765516c485f5fe82 (patch)
treedf55477f487baedc77b667e1d708462c14f8ca39 /gnu/packages/pcre.scm
parent2459cff9ae900cfa5aad402dc7694445278c884b (diff)
downloadguix-7db9573e862ccbb44221d3e4765516c485f5fe82.tar.gz
gnu: Add pcre2-10.36.
* gnu/packages/pcre.scm (pcre2-10.36): New variable.

Co-Authored-By: zimoun <zimoun.toutoune@gmail.com>.
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/pcre.scm')
-rw-r--r--gnu/packages/pcre.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index ab48168567..bc0e285001 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -7,6 +7,8 @@
 ;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -125,3 +127,16 @@ own native API, as well as a set of wrapper functions that correspond to the
 POSIX regular expression API.")
    (license license:bsd-3)
    (home-page "https://www.pcre.org/")))
+
+(define-public pcre2-10.36
+  (package
+    (inherit pcre2)
+    (name "pcre2")
+    (version "10.36")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/pcre/pcre2/"
+                                  version "/pcre2-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "0p3699msps07p40g9426lvxa3b41rg7k2fn7qxl2jm0kh4kkkvx9"))))))