summary refs log tree commit diff
path: root/gnu/packages/pcre.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-08 10:29:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-01-27 16:24:18 +0200
commit2bae32e1b9fbc254eb5ff245441add8ff900450c (patch)
tree914f17a32f9fe0a0612b1ff1b917c7ce5403bf13 /gnu/packages/pcre.scm
parent89022186256d7d0478b3e99ab664e507c6f0454b (diff)
downloadguix-2bae32e1b9fbc254eb5ff245441add8ff900450c.tar.gz
gnu: pcre2: Fix building on riscv64-linux.
* gnu/packages/pcre.scm (pcre2)[arguments]: Adjust configure-flags to not
build with JIT when building for riscv64-linux.
Diffstat (limited to 'gnu/packages/pcre.scm')
-rw-r--r--gnu/packages/pcre.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index cf8c1fb2b0..10e29cf6ca 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -109,7 +109,9 @@ POSIX regular expression API.")
                           "--enable-pcre2-16"
                           "--enable-pcre2-32"
                           ;; pcre2_jit_test fails on powerpc32.
-                          ,@(if (target-ppc32?)
+                          ;; riscv64-linux is an unsupported architecture.
+                          ,@(if (or (target-ppc32?)
+                                    (target-riscv64?))
                               '()
                               `("--enable-jit"))
                           "--disable-static")