summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-09-12 19:25:32 +0000
committerChristopher Baines <mail@cbaines.net>2022-09-17 19:09:45 +0200
commit140a08d44abab24c0476beb201c3d4c21fcde580 (patch)
treee2e5ce080701d08d122c22876c34a24c24fa957f /gnu/packages/pdf.scm
parent5d22261db3d5099d745b9e8c8484545e546b319e (diff)
downloadguix-140a08d44abab24c0476beb201c3d4c21fcde580.tar.gz
gnu: libharu: Update to 2.4.2.
* gnu/packages/pdf.scm (libharu): Update to 2.4.2.
[build-system]: Switch to cmake-build-system.
[arguments]: Remove #:configure-flags, add #:tests? and #:phases.
[inputs]: Sort them.
[native-inputs]: Remove.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm60
1 files changed, 31 insertions, 29 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 73ae2c2d0f..ca4e7f2557 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -22,6 +22,7 @@
 ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2020, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -381,36 +382,37 @@ Poppler PDF rendering library.")
 
 (define-public libharu
   (package
-   (name "libharu")
-   (version "2.3.0")
-   (source (origin
-             (method git-fetch)
-             (uri (git-reference
-                   (url "https://github.com/libharu/libharu")
-                   (commit (string-append
-                            "RELEASE_"
-                            (string-join (string-split version #\.) "_")))))
-             (file-name (git-file-name name version))
-             (sha256
-              (base32
-               "15s9hswnl3qqi7yh29jyrg0hma2n99haxznvcywmsp8kjqlyg75q"))))
-   (build-system gnu-build-system)
-   (arguments
-    `(#:configure-flags
-      (list (string-append "--with-zlib="
-                           (assoc-ref %build-inputs "zlib"))
-            (string-append "--with-png="
-                           (assoc-ref %build-inputs "libpng")))))
-   (inputs
-    (list zlib libpng))
-   (native-inputs
-    (list autoconf automake libtool))
-   (home-page "http://libharu.org/")
-   (synopsis "Library for generating PDF files")
-   (description
-    "libHaru is a library for generating PDF files.  libHaru does not support
+    (name "libharu")
+    (version "2.4.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/libharu/libharu")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1jwzqvv81zf5f7zssyixhyjirlp9ddwkbaabd177syb1bxljlsdc"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:tests? #f                  ; No tests
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'patch-cmake
+                 (lambda _
+                   (substitute* "CMakeLists.txt"
+                     (("^install\\(FILES (README\\.md CHANGES) INSTALL DESTINATION .*\\)"
+                       _ files)
+                      (format #f "install(FILES ~a DESTINATION ~a/share/doc/~a-~a)"
+                              files #$output #$name #$version))))))))
+    (inputs
+     (list libpng zlib))
+    (home-page "http://libharu.org/")
+    (synopsis "Library for generating PDF files")
+    (description
+     "libHaru is a library for generating PDF files.  libHaru does not support
 reading and editing of existing PDF files.")
-   (license license:zlib)))
+    (license license:zlib)))
 
 (define-public xpdf
   (package