summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-07 00:51:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-07 00:53:32 +0200
commit8319be779f0d780aa801c9fa1be853781c680dda (patch)
tree4f8a701e7ea9374c112f60700afd7afb5bc1ddef /gnu/packages/pdf.scm
parenteea2d5b6f74a14088e69480d36cd5dcc0a526263 (diff)
downloadguix-8319be779f0d780aa801c9fa1be853781c680dda.tar.gz
gnu: extractpdfmark: Improve package style.
* gnu/packages/pdf.scm (extractpdfmark)[arguments]: Use G-expressions.  Fix
phase name.
[native-inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 6a04c4b0f8..915f96bb3f 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -124,18 +124,18 @@
         (base32 "0yzc3ajgdfb4ssxp49g2vrki45kl144j39bg0wdn6h9dc14kzmx4"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'start-xorg-server
-           ;; The test suite wants to write to /homeless-shelter
-           (lambda _ (setenv "HOME" (getcwd)))))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'check 'set-home
+                 ;; The test suite wants to write to /homeless-shelter
+                 (lambda _ (setenv "HOME" (getcwd)))))))
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("gettext" ,gettext-minimal)
-       ("ghostscript" ,ghostscript)
-       ("pkg-config" ,pkg-config)
-       ("texlive" ,texlive-tiny)))
+     (list autoconf
+           automake
+           gettext-minimal
+           ghostscript
+           pkg-config
+           texlive-tiny))
     (inputs
      (list poppler))
     (home-page "https://github.com/trueroad/extractpdfmark")