summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 15:23:10 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:02 +0100
commitb41a05ce497d5ecc682cf46ce61aa2215193f9f6 (patch)
treedf76eaccd4a00fd741a66394a2bcf73e18dd7680 /gnu/packages/pdf.scm
parentd8013ee221bd599474340899ffb5974796091955 (diff)
downloadguix-b41a05ce497d5ecc682cf46ce61aa2215193f9f6.tar.gz
gnu: Remove work-arounds for bug 20765 (ensure uncompressed eggs).
Bug 20765 is solved since we build all Python packages using
option "--single-version-externally-managed".

* gnu/packages/bioinformatics.scm (pbtranscript-tofu): Remove
  configure-flags. (pepr): remove phase "disable-egg-generation".
* gnu/packages/pdf.scm (reportlab): Remove configure-flags.
* gnu/packages/python.scm (python-sphinx-rtd-theme, python2-elib.intl,
  python-pkgconfig, python-pytest-pep8, python-pytest-flakes): Remove
  configure-flags. (python-pillow) remove phase
  "disable-egg-generation". (python-libarchive-c) Remove patching
  setup.cfg.
* gnu/packages/statistics.scm (python-patsy): remove phase
  "prevent-generation-of-egg-archive".
* gnu/packages/tls.scm (python-acme): remove phase
  "disable-egg-compression".
* gnu/packages/tor.scm (onionshare): Remove configure-flags.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm5
1 files changed, 0 insertions, 5 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index e447ef1603..b86f5efbfa 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -638,11 +638,6 @@ using a stylus.")
                (base32
                 "0rz2pg04wnzjjm2f5a8ik9v8s54mv4xrjhv5liqjijqv6awh12gl"))))
     (build-system python-build-system)
-    (arguments
-     ;; Prevent creation of the egg. Without this flag, various artifacts
-     ;; from the build inputs end up in the final python3 output. It also
-     ;; works around https://debbugs.gnu.org/cgi/bugreport.cgi?bug=20765 .
-     `(#:configure-flags '("--single-version-externally-managed" "--root=/")))
     (propagated-inputs
      `(("python-pillow" ,python-pillow)))
     (home-page "http://www.reportlab.com")