summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-17 21:06:14 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 19:43:07 +0200
commitdf095a181390d45797459bc91d389f27179cbe2c (patch)
treed3d42a14088dfd3d6001bb12124209f7b576285b /gnu/packages/pdf.scm
parent4c8e0b32745c952bbfb9196f680003b7e1753bbf (diff)
downloadguix-df095a181390d45797459bc91d389f27179cbe2c.tar.gz
gnu: weasyprint: Use pyproject-build-system.
* gnu/packages/pdf.scm (weasyprint)[build-system]: Switch to
PYPROJECT-BUILD-SYSTEM.
[arguments]: Remove redundant phases.  Add #:test-flags.
[native-inputs]: Remove PYTHON-PYPA-BUILD.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm21
1 files changed, 4 insertions, 17 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 9e809a8382..95cc3b1e22 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1497,9 +1497,11 @@ manipulating PDF documents from the command line.  It supports
        (sha256
         (base32
          "08l0yaqg0rxnb2r3x4baf4wng5pxpjbyalnrl4glwh9l69740q7p"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      (list
+      #:test-flags #~(list "-vv" "-c" "/dev/null"
+                           "-n" (number->string (parallel-job-count)))
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'patch-library-paths
@@ -1520,21 +1522,7 @@ manipulating PDF documents from the command line.  It supports
                 (("'pangoft2-1.0-0'")
                  (format #f "~s"
                          (search-input-file inputs
-                                            "lib/libpangoft2-1.0.so"))))))
-          ;; XXX: PEP 517 manual build copied from python-isort.
-          (replace 'build
-            (lambda _
-              (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                (invoke "pytest" "-vv" "-c" "/dev/null"
-                        "-n" (number->string (parallel-job-count))))))
-          (replace 'install
-            (lambda _
-              (let ((whl (car (find-files "dist" "\\.whl$"))))
-                (invoke "pip" "--no-cache-dir" "--no-input"
-                        "install" "--no-deps" "--prefix" #$output whl)))))))
+                                            "lib/libpangoft2-1.0.so")))))))))
     (inputs (list fontconfig glib harfbuzz pango))
     (propagated-inputs
      (list gdk-pixbuf
@@ -1552,7 +1540,6 @@ manipulating PDF documents from the command line.  It supports
      (list font-dejavu                  ;tests depend on it
            ghostscript
            python-flit-core
-           python-pypa-build
            python-pytest
            python-pytest-xdist))
     (home-page "https://weasyprint.org/")