summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-10-05 19:08:03 -0400
committerMark H Weaver <mhw@netris.org>2014-10-05 22:39:37 -0400
commitf410c1107622f9a95073234eae18c623857338d4 (patch)
treeddd6f0cb234fa94ff838099fb7c24e19b7aea05c /gnu/packages/pdf.scm
parent553521d27c42cf7589d50daab1aeaeb9bc9e8e96 (diff)
downloadguix-f410c1107622f9a95073234eae18c623857338d4.tar.gz
gnu: xpdf: Update to 3.04.
* gnu/packages/patches/xpdf-constchar.patch: Remove.
* gnu-system.am (dist_patch_DATA): Remove it.
* gnu/packages/pdf.scm (xpdf): Update to 3.04.  Remove patch.
  Add libpng as an input.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index d6d97c1ea8..7ffdde04ae 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -85,14 +85,13 @@
 (define-public xpdf
   (package
    (name "xpdf")
-   (version "3.03")
+   (version "3.04")
    (source (origin
             (method url-fetch)
             (uri (string-append "ftp://ftp.foolabs.com/pub/xpdf/xpdf-"
                                 version ".tar.gz"))
             (sha256 (base32
-                     "1jnfzdqc54wa73lw28kjv0m7120mksb0zkcn81jdlvijyvc67kq2"))
-            (patches (list (search-patch "xpdf-constchar.patch")))))
+                     "1rbp54mr3z2x3a3a1qmz8byzygzi223vckfam9ib5g1sfds0qf8i"))))
    (build-system gnu-build-system)
    (inputs `(("freetype" ,freetype)
              ("gs-fonts" ,gs-fonts)
@@ -103,6 +102,7 @@
              ("libxp" ,libxp)
              ("libxpm" ,libxpm)
              ("libxt" ,libxt)
+             ("libpng" ,libpng)
              ("zlib" ,zlib)))
    (arguments
     `(#:tests? #f ; there is no check target