summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2016-10-30 16:37:28 +0530
committerLudovic Courtès <ludo@gnu.org>2016-11-03 14:33:50 +0100
commit5d68e9d6204333e7ce9d43645a7a49f0dca23270 (patch)
tree0b4f3748823d9c9b84b8a72572e2b83e23f61aa7 /gnu/packages/pdf.scm
parent05e3865e07f76de24d4d98351043f2d0ad73a6a8 (diff)
downloadguix-5d68e9d6204333e7ce9d43645a7a49f0dca23270.tar.gz
gnu: Add pdf2svg.
* gnu/packages/pdf.scm (pdf2svg): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 42547dff9b..8aabacc9cc 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -8,6 +8,7 @@
 ;;; Coypright © 2016 Marius Bakke <mbakke@fastmail.com>
 ;;; Coypright © 2016 Ludovic Courtès <ludo@gnu.org>
 ;;; Coypright © 2016 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -751,3 +752,28 @@ the PDF pages.")
 the framebuffer.")
 
     (license license:gpl2+)))
+
+(define-public pdf2svg
+  (package
+    (name "pdf2svg")
+    (version "0.2.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/dawbarton/pdf2svg/archive/v"
+                    version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "12pa1pajirnlrkz2il3h4l30lc2prryk1qr132jk6z9y1c3qdcag"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("cairo" ,cairo)
+       ("poppler" ,poppler)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://www.cityinthesky.co.uk/opensource/pdf2svg/")
+    (synopsis "PDF to SVG converter")
+    (description "@command{pdf2svg} is a simple command-line PDF to SVG
+converter using the Poppler and Cairo libraries.")
+    (license license:gpl2+)))