summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-24 01:31:41 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-24 12:15:32 +0100
commit6c1c5fecd6a1af29de8deff3ab35cfc5865e8cb7 (patch)
tree9fc01cfeeaafd2aa6c1ba76e6048c9b5a9ee14a6 /gnu/packages/pdf.scm
parentc5427f016ab1c4259a74d142747181032034ad55 (diff)
downloadguix-6c1c5fecd6a1af29de8deff3ab35cfc5865e8cb7.tar.gz
gnu: mupdf: Prepare for cross-compilation.
* gnu/packages/pdf.scm (mupdf)[arguments]: Use CC-FOR-TARGET.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 59c8c02114..235950c038 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -724,8 +724,8 @@ extracting content or merging files.")
     (native-inputs
       `(("pkg-config" ,pkg-config)))
     (arguments
-      '(#:tests? #f                     ; no check target
-        #:make-flags (list "CC=gcc"
+      `(#:tests? #f                     ; no check target
+        #:make-flags (list (string-append "CC=" ,(cc-for-target))
                            "XCFLAGS=-fpic"
                            "USE_SYSTEM_LIBS=yes"
                            "USE_SYSTEM_MUJS=yes"