summary refs log tree commit diff
path: root/gnu/packages/pep.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-05-04 21:04:24 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-05-31 10:45:53 +0200
commitc178f859b5f549da5d064e628a5906d505dd75ef (patch)
tree22e2e4d8c7b6c86b9fd201b2e789c08fe1a77d94 /gnu/packages/pep.scm
parent85d80283b6d14b19dacdd687590eba494da4864f (diff)
downloadguix-c178f859b5f549da5d064e628a5906d505dd75ef.tar.gz
gnu: libpEpAdapter: Update to 2.1.21.
* gnu/packages/pep.scm (libpEpAdapter): Update to 2.1.21.
  [source]: Swicht to new git repo.
  [arguments]<make-flags>: Enable release-build.
Diffstat (limited to 'gnu/packages/pep.scm')
-rw-r--r--gnu/packages/pep.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/pep.scm b/gnu/packages/pep.scm
index 6ee01b9df5..fc6f299c4e 100644
--- a/gnu/packages/pep.scm
+++ b/gnu/packages/pep.scm
@@ -147,20 +147,21 @@ privacy).")
 (define-public libpepadapter
   (package
     (name "libpepadapter")
-    (version "2.0.2")
+    (version "2.1.21")
     (source
      (origin
-       (method hg-fetch)
-       (uri (hg-reference
-             (url "https://pep.foundation/dev/repos/libpEpAdapter")
-             (changeset "e8fe371c870a"))) ;; r168
-       (file-name (string-append name "-" version "-checkout"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitea.pep.foundation/pEp.foundation/libpEpAdapter")
+             (commit (string-append "Release_" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "1mlpavjbnmslvmr5jxcvpjgb2x40nhmxjb10hza3kn4qzj0k1pjz"))))
+        (base32 "09ljj3x09y99wc47n063hpn62zi8cdvdha82rnaypvirrlga6a5w"))))
     (build-system gnu-build-system)
     (arguments
      '(#:test-target "test"
        #:tests? #f ;; building the tests fails
+       #:make-flags '("NDEBUG=1") ; release build
        #:phases
        (modify-phases %standard-phases
          (replace 'configure
@@ -170,7 +171,7 @@ privacy).")
              (let ((out (assoc-ref outputs "out"))
                    (engine (assoc-ref inputs "pep-engine")))
                (with-output-to-file "local.conf"
-                 (lambda _ ;()
+                 (lambda _
                    (format #t "
 PREFIX=~a
 ENGINE_LIB_PATH=~a/lib