summary refs log tree commit diff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-14 01:42:02 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 01:42:02 +0100
commitbb4674b43fa413a6d41694b2093c3b00d11eea47 (patch)
treee9de75e813e90459c5313ba73ac22473b0e0e565 /gnu/packages/perl-check.scm
parent41c6e4f2b40f41cdbf4e8c7ade29845709f9cdf4 (diff)
parent989d564f4434c6e43df7ccb0d1701e89e243e404 (diff)
downloadguix-bb4674b43fa413a6d41694b2093c3b00d11eea47.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 75e858609f..67bdfd81c4 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -66,9 +66,9 @@ implementation as used in cperl.  It does not store the mocked overrides
 lexically, just dynamically.")
     (license artistic2.0)))
 
-(define-public perl-test2-bundle-extended
+(define-public perl-test2-suite
   (package
-    (name "perl-test2-bundle-extended")
+    (name "perl-test2-suite")
     (version "0.000072")
     (source
       (origin
@@ -88,7 +88,7 @@ lexically, just dynamically.")
      `(("perl-importer" ,perl-importer)
        ("perl-term-table" ,perl-term-table)
        ("perl-sub-info" ,perl-sub-info)))
-    (home-page "https://metacpan.org/pod/Test2::Bundle::Extended")
+    (home-page "https://metacpan.org/pod/Test2-Suite")
     (synopsis "Full set of tools for Test2::Suite")
     (description "This package provides a rich set of tools, plugins, bundles,
 etc built upon the Test2 testing library.")
@@ -107,8 +107,10 @@ etc built upon the Test2 testing library.")
          (base32
           "002qk6qsm0l6r2kaxywvc38w0yf0mlavgywq8li076pn6kcw3242"))))
     (build-system perl-build-system)
+    (native-inputs
+     `(("perl-ipc-run3" ,perl-ipc-run3)))
     (propagated-inputs
-     `(("perl-test2-bundle-extended" ,perl-test2-bundle-extended)))
+     `(("perl-test2-suite" ,perl-test2-suite)))
     (home-page "https://metacpan.org/release/Test2-Plugin-NoWarnings")
     (synopsis "Fail if tests warn")
     (description "Loading this plugin causes your tests to fail if there any