summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorThiago Jung Bauermann <bauermann@kolabnow.com>2022-10-09 02:08:23 -0300
committerLudovic Courtès <ludo@gnu.org>2022-10-09 22:32:14 +0200
commitfa3ba0143fee0b8ccbd0371cc37c1435d4f2a68f (patch)
treefb5343baa0298733f889f1444dd58effca1dd035 /gnu/packages/perl.scm
parent31f0e46bea4028d2830f384afeaa7999004716c5 (diff)
downloadguix-fa3ba0143fee0b8ccbd0371cc37c1435d4f2a68f.tar.gz
gnu: Add perl-file-fcntllock.
* gnu/packages/perl.scm (perl-file-fcntllock): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 64868607dc..5f3666fe3b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11641,6 +11641,28 @@ method calls.  Furthermore, a partial sequence can be created and held, and
 used as the head of many different sequences.")
     (license license:perl-license)))
 
+(define-public perl-file-fcntllock
+  (package
+    (name "perl-file-fcntllock")
+    (version "0.22")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/J/JT/JTT/File-FcntlLock-" version
+                    ".tar.gz"))
+              (sha256
+               (base32
+                "1pxwknq4lw0wqpkh8pf18qsjf9g503vx6a5184vvffprzwpbp6ls"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/release/File-FcntlLock")
+    (synopsis "File locking with fcntl(2)")
+    (description "File locking in Perl is usually done using the @code{flock}
+function.  Unfortunately, this only allows locks on whole files and is often
+implemented in terms of the @code{flock(2)} system function which has some
+shortcomings (especially concerning locks on remotely mounted file systems)
+and slightly different behaviour than @code{fcntl(2)}.")
+    (license license:perl-license)))
+
 (define-public perl-font-ttf
   (package
     (name "perl-font-ttf")