summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorAlex Sassmannshausen <alex@pompo.co>2017-03-23 13:17:36 +0100
committerAlex Sassmannshausen <alex@pompo.co>2017-03-26 11:33:35 +0200
commit033dec64ccfb48c54672c0467d711335acf2d0ca (patch)
tree126cb1d853b5687a590bd84a69ab38bdb2375936 /gnu/packages/perl.scm
parent21b7cf4287f5afec1ad5d969aec465f3f7261bd0 (diff)
downloadguix-033dec64ccfb48c54672c0467d711335acf2d0ca.tar.gz
gnu: Add perl-test-needs.
* gnu/packages/perl.scm (perl-test-needs): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 4944ceb2a2..ce2c59e4ca 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6761,6 +6761,34 @@ functions, along with automatically turning on strict and warning and gives a
 bit more fine-grained control over test suites.")
     (license (package-license perl))))
 
+(define-public perl-test-needs
+  (package
+    (name "perl-test-needs")
+    (version "0.002005")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/H/HA/HAARG/Test-Needs-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "16gkgpmr9hvkz382iaqd3500269lk2d44fqaw3dsrvc66nc36kss"))))
+    (build-system perl-build-system)
+    (home-page
+     "http://search.cpan.org/dist/Test-Needs")
+    (synopsis
+     "Skip tests when modules not available")
+    (description "@code{Test::Needs} allows you to skip test scripts if
+modules are not available.  The requested modules will be loaded, and
+optionally have their versions checked.  If the module is missing, the test
+script will be skipped.  Modules that are found but fail to compile will exit
+with an error rather than skip.
+
+If used in a subtest, the remainder of the subtest will be skipped.")
+    (license (package-license perl))))
+
 (define-public perl-test-nowarnings
   (package
     (name "perl-test-nowarnings")