summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2022-12-31 23:04:57 +0900
committerJulien Lepiller <julien@lepiller.eu>2023-01-03 20:51:44 +0100
commitfae9d65034d95e1b33416936af7aae3d8e790f03 (patch)
treed297ecbad48f6ed034d531bf9c51e0b0808a103e /gnu/packages/perl.scm
parent62ee1c4b47c6e1e62314223d62a5d54162a23fa8 (diff)
downloadguix-fae9d65034d95e1b33416936af7aae3d8e790f03.tar.gz
gnu: Add perl-xs-parse-keyword
perl-xs-parse-keyword v0.06 is required by perl-syntax-keyword-try.
Note that the latest version of this package is 0.31.

* gnu/packages/perl.scm (perl-xs-parse-keyword): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 7f85c2a66a..7684a2007f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11581,6 +11581,28 @@ supersede Perl's builtin @code{T_PTROBJ} with something that is extensible
 neither visible nor modifiable from Perl space).")
     (license (package-license perl))))
 
+(define-public perl-xs-parse-keyword
+  (package
+    (name "perl-xs-parse-keyword")
+    (version "0.06")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/P/PE/PEVANS/XS-Parse-Keyword-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0nnr8akkxb2h2y3d5r51pr84vvxkq89ynmi9azkbnn79jmbcbgvq"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-module-build perl-test-simple))
+    (home-page "https://metacpan.org/dist/XS-Parse-Keyword")
+    (synopsis "XS functions to assist in parsing keyword syntax")
+    (description
+     "This module provides some XS functions to assist in writing
+syntax modules that provide new perl-visible syntax, primarily for authors of
+keyword plugins using the @code{PL_keyword_plugin} hook mechanism.")
+    (license (package-license perl))))
+
 (define-public perl-yaml
   (package
     (name "perl-yaml")