summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-10-24 18:26:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-24 18:38:32 +0200
commit22473f6964096fe5d938b7955275c135252cb002 (patch)
tree7a8ccf1af6eb3b5dfc03dbb07e905395c2e93629 /gnu/packages/perl.scm
parent35aaf4b1bd146f9f0277b9484e05470ec7424738 (diff)
downloadguix-22473f6964096fe5d938b7955275c135252cb002.tar.gz
gnu: Add perl-types-path-tiny.
* gnu/packages/perl.scm (perl-types-path-tiny): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index e1e15bd076..c392c305a4 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8736,6 +8736,32 @@ package has only core dependencies, and does not depend on @code{Type::Tiny},
 so other data validation frameworks might also consider using it.")
     (license perl-license)))
 
+(define-public perl-types-path-tiny
+  (package
+    (name "perl-types-path-tiny")
+    (version "0.005")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
+                           "Types-Path-Tiny-" version ".tar.gz"))
+       (sha256
+        (base32
+         "09nf167ssi4rgj8hhzylwp3zdx61njdpyfri43arcmk9aqn7f0pp"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-file-pushd" ,perl-file-pushd)
+       ("perl-path-tiny" ,perl-path-tiny)
+       ("perl-type-tiny" ,perl-type-tiny)
+       ("perl-exporter-tiny" ,perl-exporter-tiny)))
+    (home-page "http://search.cpan.org/dist/Types-Path-Tiny/")
+    (synopsis "Types and coercions for Moose and Moo")
+    (description "This module provides @code{Path::Tiny} types for Moose, Moo,
+etc.  It handles two important types of coercion: coercing objects with
+overloaded stringification, and coercing to absolute paths.  It also can check
+to ensure that files or directories exist.")
+    (license artistic2.0)))
+
 (define-public perl-types-serialiser
   (package
     (name "perl-types-serialiser")