summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorThiago Jung Bauermann <bauermann@kolabnow.com>2021-07-24 22:58:26 -0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-25 11:58:38 +0300
commit52cc6394033546406b81c146d38104c1d80dc68f (patch)
treeea5ebd16aced4b1735999e2ee13791a8d51d4a91 /gnu/packages/perl.scm
parentb8894e8065643fb05fbf0cea4b6ee98658dd0fdf (diff)
downloadguix-52cc6394033546406b81c146d38104c1d80dc68f.tar.gz
gnu: perl: Use ‘search-input-file’ to find ‘bin/pwd’
A recent change makes the ‘perl’ package explicitly reference input
“coreutils” or “coreutils-minimal” by label in the ‘setup-configure’ phase
but the ‘perl-boot0’ package, which uses ‘%boot0-inputs’ as its input list,
doesn’t have such input on non-x86-linux systems. This causes the build of
‘perl-boot0’ to fail on those systems.

Therefore use ‘search-input-file’ to find ‘bin/pwd’ and avoid referencing
the input label.

* gnu/packages/perl.scm (perl)[arguments]<#:phases>: Use
‘search-input-file’ to find ‘bin/pwd’.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 040898b423..99a152e0ab 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -124,18 +124,16 @@
        (modify-phases %standard-phases
          (add-before 'configure 'setup-configure
            (lambda* (#:key inputs #:allow-other-keys)
-             (let ((coreutils (or (assoc-ref inputs "coreutils-minimal")
-                                  (assoc-ref inputs "coreutils"))))
-               ;; Use the right path for `pwd'.
-               (substitute* "dist/PathTools/Cwd.pm"
-                 (("'/bin/pwd'")
-                  (string-append "'" coreutils "/bin/pwd'")))
-
-               ;; Build in GNU89 mode to tolerate C++-style comment in libc's
-               ;; <bits/string3.h>.
-               (substitute* "cflags.SH"
-                 (("-std=c89")
-                  "-std=gnu89")))))
+             ;; Use the right path for `pwd'.
+             (substitute* "dist/PathTools/Cwd.pm"
+               (("'/bin/pwd'")
+                (string-append "'" (search-input-file inputs "bin/pwd") "'")))
+
+             ;; Build in GNU89 mode to tolerate C++-style comment in libc's
+             ;; <bits/string3.h>.
+             (substitute* "cflags.SH"
+               (("-std=c89")
+                "-std=gnu89"))))
          ,@(if (%current-target-system)
                `((add-after 'unpack 'unpack-cross
                    (lambda* (#:key native-inputs inputs #:allow-other-keys)