summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-04-04 15:22:19 +0200
committerRoel Janssen <roel@gnu.org>2018-04-04 15:22:19 +0200
commit5a6e23fb1bfc50e62f8b9b7c92dac5686c762677 (patch)
tree8f3987d92358cc059d8c3312d4d8270627b67152 /gnu/packages/perl.scm
parente1478563979db6d36acccbc6f2bab749c295d68d (diff)
downloadguix-5a6e23fb1bfc50e62f8b9b7c92dac5686c762677.tar.gz
gnu: Add perl-math-round.
* gnu/packages/perl.scm (perl-math-round): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 7bb43e4620..3f1693c9d7 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4760,6 +4760,25 @@ Build a Mail::Internet object, and then send it out using Mail::Mailer.
 @end table")
     (license perl-license)))
 
+(define-public perl-math-round
+  (package
+    (name "perl-math-round")
+    (version "0.07")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/G/GR/GROMMEL/Math-Round-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "09wkvqj4hfq9y0fimri967rmhnq90dc2wf20lhlmqjp5hsd359vk"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Math-Round/")
+    (synopsis "Perl extension for rounding numbers")
+    (description "@code{Math::Round} provides functions to round numbers,
+both positive and negative, in various ways.")
+    (license perl-license)))
+
 (define-public perl-memoize
   (package
     (name "perl-memoize")