summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-07 15:30:18 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:51 -0500
commit70fe0008f7cd011f3f3c685c14341347f6bb5abe (patch)
treef0994ed289a2756acb2ef0f7760dea1fb6e48037 /gnu/packages/perl.scm
parentcd718b8201d00ef26fc49ea88a2a0a4c42358d7d (diff)
downloadguix-70fe0008f7cd011f3f3c685c14341347f6bb5abe.tar.gz
gnu: Add TermReadKey.
* gnu/packages/perl.scm (perl-term-readkey): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 38c6224b73..a4c666cc33 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4365,6 +4365,28 @@ processing in Perl code.")
 the current terminal expects in various ways.")
     (license (package-license perl))))
 
+(define-public perl-term-readkey
+  (package
+    (name "perl-term-readkey")
+    (version "2.32")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/J/JS/JSTOWE/"
+                           "TermReadKey-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1y79w5cj98w0a1nqxjhmaw01p2hfhzfw340m2qxd11p6124hxfaq"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/TermReadKey")
+    (synopsis "Simple terminal control")
+    (description "This module, ReadKey, provides ioctl control for terminals
+so the input modes can be changed (thus allowing reads of a single character
+at a time), and also provides non-blocking reads of stdin, as well as several
+other terminal related features, including retrieval/modification of the
+screen size, and retrieval/modification of the control characters.")
+    (license (package-license perl))))
+
 (define-public perl-test-base
   (package
     (name "perl-test-base")