summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2014-12-16 12:19:15 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-17 00:11:28 +0100
commit0ad3969fcd502cd1433633c1c62c921700643122 (patch)
tree1e00a64c72c2eb10a1234592c8bc51cd0f734dae /gnu/packages/perl.scm
parent9dc8a1577fdb35b0d94cc50154d83a63899adc21 (diff)
downloadguix-0ad3969fcd502cd1433633c1c62c921700643122.tar.gz
gnu: Add Test::Deep.
* gnu/packages/perl.scm (perl-test-deep): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index c8011f5e72..4135533faf 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -253,6 +253,30 @@ Perlish API and none of the bloat and rarely used features of IPC::Run.")
     ;; licenses, any version."
     (license (list bsd-3 gpl3+))))
 
+(define-public perl-test-deep
+  (package
+    (name "perl-test-deep")
+    (version "0.114")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://cpan/authors/id/R/RJ/RJBS/"
+                                  "Test-Deep-" version ".tar.gz"))
+              (sha256
+               (base32
+                "09yr47vw7vj27sdik312x08938higcij8ybyq8k67mlccx8cpqf0"))))
+    (build-system perl-build-system)
+    (inputs `(("perl-test-tester" ,perl-test-tester)
+              ("perl-test-nowarnings" ,perl-test-nowarnings)))
+    (synopsis "Flexible deep comparison for the Test::Builder framework")
+    (description
+     "Test::Deep compares two structures by going through each level, ensuring
+that the values match, that arrays and hashes have the same elements and that
+references are blessed into the correct class. It also handles circular data
+structures without getting caught in an infinite loop.")
+    (home-page (string-append "http://search.cpan.org/~rjbs/"
+                              "Test-Deep-" version))
+    (license gpl1+)))  ; or "Artistic License"
+
 (define-public perl-test-nowarnings
   (package
     (name "perl-test-nowarnings")