summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-27 12:42:22 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-27 12:42:22 +0100
commit8779987bba029535d3dc00f1aacf59281fdd34f0 (patch)
tree7a6d616d45367d508f94c3593b1ce5c7053c33f5 /gnu/packages/perl.scm
parent1885bb0c08e943a2e0e37c5c0a83473c8af904d0 (diff)
parenta6d9f8837b118e2126e4b8a19bf48b524229a15c (diff)
downloadguix-8779987bba029535d3dc00f1aacf59281fdd34f0.tar.gz
Merge branch 'master' into python-tests
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index fb294eb42d..eee688354a 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5746,6 +5746,26 @@ access the DOM object, create and access Javascript, and generate SMIL
 animation content.")
     (license (package-license perl))))
 
+(define-public perl-switch
+  (package
+    (name "perl-switch")
+    (version "2.17")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/C/CH/CHORNY/Switch-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "0xbdjdgzfj9zwa4j3ipr8bfk7bcici4hk89hq5d27rhg2isljd9i"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Switch")
+    (synopsis "Switch statement for Perl")
+    (description "Switch is a Perl module which implements a generalized case
+mechanism.  The module augments the standard Perl syntax with two new
+statements: @code{switch} and @code{case}.")
+    (license (package-license perl))))
+
 (define-public perl-sys-cpu
   (package
     (name "perl-sys-cpu")