summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 15:50:08 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:27 -0600
commit5f600011335347a8714861deb463e3287b610587 (patch)
tree53d8bfe8b4d6404058ce0acc99b78c8e37bd8d3b /gnu/packages/perl.scm
parent85e92c32c6e5a696e7689bd1b1cac7036e5b83ed (diff)
downloadguix-5f600011335347a8714861deb463e3287b610587.tar.gz
gnu: Add Variable-Magic.
* gnu/packages/perl.scm (perl-variable-magic): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index cad6124686..173ff8cd39 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -891,6 +891,28 @@ that are designed to minimize common mistakes with eval blocks, and nothing
 else.")
     (license x11)))
 
+(define-public perl-variable-magic
+  (package
+    (name "perl-variable-magic")
+    (version "0.55")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/V/VP/VPIT/"
+                           "Variable-Magic-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0xzh2vy45ph80bp09j5fcjy8ydgn8yaxsa0fj831q6p1spvyniwg"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Variable-Magic")
+    (synopsis "Associate user-defined magic to variables from Perl")
+    (description "Magic is Perl's way of enhancing variables.  This mechanism
+lets the user add extra data to any variable and hook syntactical
+operations (such as access, assignment or destruction) that can be applied to
+it.  With this module, you can add your own magic to any variable without
+having to write a single line of XS.")
+    (license (package-license perl))))
+
 
 ;;; Some packaged modules need versions of core modules that are newer than
 ;;; those in our perl 5.16.1.