summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-23 22:47:39 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-23 23:33:09 +0100
commit12abb19dfbd90089e04ccbc94f0bd8ee2cbe3729 (patch)
tree2c85197829465c6d48075166bd313d6c228508ef /gnu/packages/perl.scm
parentbbb7a00e9a224d812a56c67956efb3e8a840cf0a (diff)
downloadguix-12abb19dfbd90089e04ccbc94f0bd8ee2cbe3729.tar.gz
gnu: Remove unnecessary closures around `arguments' value.
* gnu/packages/algebra.scm (pari-gp): Remove closure around the value of
  `arguments'.
* gnu/packages/bdb.scm (bdb): Likewise.
* gnu/packages/mit-krb5.scm (mit-krb5): Likewise.
* gnu/packages/openssl.scm (openssl): Likewise.
* gnu/packages/perl.scm (perl): Likewise.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm49
1 files changed, 24 insertions, 25 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index a37202b7bb..5d5b7ac099 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -38,32 +38,31 @@
                "15qxzba3a50c9nik5ydgyfp62x7h9vxxn12yd1jgl93hb1wj96km"))))
     (build-system gnu-build-system)
     (arguments
-     (lambda (system)
-       `(#:tests? #f
-         #:patches (list (assoc-ref %build-inputs "patch/no-sys-dirs"))
-         #:phases
-         (alist-replace
-          'configure
-          (lambda* (#:key inputs outputs #:allow-other-keys)
-            (let ((out  (assoc-ref outputs "out"))
-                  (libc (assoc-ref inputs "libc")))
-              ;; Use the right path for `pwd'.
-              (substitute* "dist/Cwd/Cwd.pm"
-                (("/bin/pwd")
-                 (which "pwd")))
+     '(#:tests? #f
+       #:patches (list (assoc-ref %build-inputs "patch/no-sys-dirs"))
+       #:phases
+       (alist-replace
+        'configure
+        (lambda* (#:key inputs outputs #:allow-other-keys)
+          (let ((out  (assoc-ref outputs "out"))
+                (libc (assoc-ref inputs "libc")))
+            ;; Use the right path for `pwd'.
+            (substitute* "dist/Cwd/Cwd.pm"
+              (("/bin/pwd")
+               (which "pwd")))
 
-              (zero?
-               (system* "./Configure"
-                        (string-append "-Dprefix=" out)
-                        (string-append "-Dman1dir=" out "/share/man/man1")
-                        (string-append "-Dman3dir=" out "/share/man/man3")
-                        "-de" "-Dcc=gcc"
-                        "-Uinstallusrbinperl"
-                        "-Dinstallstyle=lib/perl5"
-                        "-Duseshrplib"
-                        (string-append "-Dlocincpth=" libc "/include")
-                        (string-append "-Dloclibpth=" libc "/lib")))))
-          %standard-phases))))
+            (zero?
+             (system* "./Configure"
+                      (string-append "-Dprefix=" out)
+                      (string-append "-Dman1dir=" out "/share/man/man1")
+                      (string-append "-Dman3dir=" out "/share/man/man3")
+                      "-de" "-Dcc=gcc"
+                      "-Uinstallusrbinperl"
+                      "-Dinstallstyle=lib/perl5"
+                      "-Duseshrplib"
+                      (string-append "-Dlocincpth=" libc "/include")
+                      (string-append "-Dloclibpth=" libc "/lib")))))
+        %standard-phases)))
     (inputs `(("patch/no-sys-dirs" ,(search-patch "perl-no-sys-dirs.patch"))))
     (synopsis "Implementation of the Perl programming language")
     (description