summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-19 22:37:22 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-19 23:14:59 +0100
commit113dabe831f5df1f5a745ee3c68c5ccd158e7141 (patch)
treec82dc93471a1ff605a033e674c40f943ae1c4c64 /gnu/packages/perl.scm
parent1c701708a718f9bd5b3e0e6ebde25e2204ab6222 (diff)
downloadguix-113dabe831f5df1f5a745ee3c68c5ccd158e7141.tar.gz
gnu: Add perl-statistics-pca.
* gnu/packages/perl.scm (perl-statistics-pca): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index ea520fe65a..23c3d38f2f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -70,6 +70,7 @@
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl-check)
   #:use-module (gnu packages perl-compression)
+  #:use-module (gnu packages perl-maths)
   #:use-module (gnu packages perl-web)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages readline)
@@ -8955,6 +8956,32 @@ which it is called.")
 @code{median()}, @code{mean()}, @code{variance()} and @code{stddev()}.")
     (license license:lgpl2.0)))
 
+(define-public perl-statistics-pca
+  (package
+    (name "perl-statistics-pca")
+    (version "0.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/D/DS/DSTH/Statistics-PCA-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1i3bskwibp54c9a2wx8gzr3hyds6mmhr3d550g8j6893005v3bgq"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-module-build" ,perl-module-build)))
+    (propagated-inputs
+     `(("perl-contextual-return" ,perl-contextual-return)
+       ("perl-math-cephes" ,perl-math-cephes)
+       ("perl-math-matrixreal" ,perl-math-matrixreal)
+       ("perl-text-simpletable" ,perl-text-simpletable)))
+    (home-page "https://metacpan.org/release/Statistics-PCA")
+    (synopsis "Perl implementation of Principal Component Analysis")
+    (description "This package provides the Statistics::PCA module, an
+implementation of @dfn{Principal Component Analysis} (PCA).")
+    (license license:perl-license)))
+
 (define-public perl-stream-buffered
   (package
     (name "perl-stream-buffered")