summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-09 18:00:55 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-02 18:39:14 +0100
commit647b6d3847a56c9b95e505cdb6e18a261329f998 (patch)
tree4620ccd7e908fb2720b63983db089b9a43b4f0a3 /gnu/packages/perl.scm
parent811f4f5b4c0e5a58d2aef06f871e1bbd59e2156b (diff)
downloadguix-647b6d3847a56c9b95e505cdb6e18a261329f998.tar.gz
gnu: Add perl-canary-stability.
* gnu/packages/perl.scm (perl-canary-stability): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index f80a95f3e0..4c51681bab 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -596,6 +596,25 @@ code or from an external program.  Optionally, output can be teed so that it
 is captured while being passed through to the original file handles.")
     (license asl2.0)))
 
+(define-public perl-canary-stability
+  (package
+    (name "perl-canary-stability")
+    (version "2012")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://cpan/authors/id/M/ML/MLEHMANN/"
+                                  "Canary-Stability-" version ".tar.gz"))
+              (sha256
+               (base32
+                "01vih43hvpqy67m6a6fwmlswli91mqpv8n8ccglvlkc33l8hn97x"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Canary-Stability")
+    (synopsis "Check compatibility with the installed perl version")
+    (description
+     "This module is used by Schmorp's modules during configuration stage
+to test the installed perl for compatibility with his modules.")
+    (license (package-license perl))))
+
 (define-public perl-carp-assert
   (package
     (name "perl-carp-assert")