summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-27 17:44:54 -0400
committerLeo Famulari <leo@famulari.name>2017-07-30 20:10:39 -0400
commit6d6646f9326a8c5c853cd41dc74938b899f5cbd5 (patch)
treea1d1f64659ab037c937ec03444e8c18c7b3fa329 /gnu/packages/perl.scm
parentb51f02a94939e7f8a3d85b24f45fc0ea75d7c979 (diff)
downloadguix-6d6646f9326a8c5c853cd41dc74938b899f5cbd5.tar.gz
gnu: Add perl-term-table.
* gnu/packages/perl.scm (perl-term-table): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index c8ea0fd5a5..e3dee0f9b2 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6431,6 +6431,27 @@ other terminal related features, including retrieval/modification of the
 screen size, and retrieval/modification of the control characters.")
     (license (package-license perl))))
 
+(define-public perl-term-table
+  (package
+    (name "perl-term-table")
+    (version "0.008")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "mirror://cpan/authors/id/E/EX/EXODIST/Term-Table-"
+                            version ".tar.gz"))
+        (sha256
+         (base32
+          "0gi4lyvs6n8y6hjwmflfpamfl65y7mb1g39zi0rx35nclj8xb370"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-importer" ,perl-importer)))
+    (home-page "http://search.cpan.org/dist/Term-Table/")
+    (synopsis "Format a header and rows into a table")
+    (description "This module is able to generically format rows of data
+into tables.")
+    (license (package-license perl))))
+
 (define-public perl-test-base
   (package
     (name "perl-test-base")