summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 15:30:07 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:26 -0600
commit185082c864e8035422544cb48bbaae4780af7e1e (patch)
tree761df761821821757feead8e285844d3af0ec87c /gnu/packages/perl.scm
parent07b2c25486a6fcac3499f56ebb38e02384e42ad1 (diff)
downloadguix-185082c864e8035422544cb48bbaae4780af7e1e.tar.gz
gnu; Add Module-Runtime.
* gnu/packages/perl.scm (perl-module-runtime): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index b98598d080..b0bd7c2094 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -369,6 +369,25 @@ Perlish API and none of the bloat and rarely used features of IPC::Run.")
     ;; licenses, any version."
     (license (list bsd-3 gpl3+))))
 
+(define-public perl-module-runtime
+  (package
+    (name "perl-module-runtime")
+    (version "0.014")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/Z/ZE/ZEFRAM/"
+                           "Module-Runtime-" version ".tar.gz"))
+       (sha256
+        (base32
+         "19326f094jmjs6mgpwkyisid54k67w34br8yfh0gvaaml87gwi2c"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Module-Runtime")
+    (synopsis "Perl runtime module handling")
+    (description "The functions exported by this module deal with runtime
+handling of Perl modules, which are normally handled at compile time.")
+    (license (package-license perl))))
+
 (define-public perl-params-util
   (package
     (name "perl-params-util")