summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-11-03 15:28:10 +0100
committerAndreas Enge <andreas@enge.fr>2019-11-05 22:08:39 +0100
commit7f1f6b7223600ce223f5633ac04af9c4a283fd19 (patch)
treed85817961eec5c75c3cc7b269be1b703c4df65b7 /gnu/packages/perl.scm
parent9ebaab861f3c50f935d46e3800690d52ea3a5eb0 (diff)
downloadguix-7f1f6b7223600ce223f5633ac04af9c4a283fd19.tar.gz
gnu: Add perl-extutils-parsexs.
* gnu/packages/perl.scm (perl-extutils-parsexs): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 5757849357..9e02ce7656 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3412,6 +3412,29 @@ C code in your Perl programs, there isn't a clear method to compile standard,
 self-contained C libraries.  This module main goal is to help in that task.")
     (license (package-license perl))))
 
+(define-public perl-extutils-parsexs
+  (package
+    (name "perl-extutils-parsexs")
+    (version "3.35")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "mirror://cpan/authors/id/S/SM/SMUELLER/ExtUtils-ParseXS-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "077fqiyabydm8j34wxzxwxskyidh8nmwq9gskaxai8kq298z1pj1"))))
+    (build-system perl-build-system)
+    (home-page
+      "https://metacpan.org/release/ExtUtils-ParseXS")
+    (synopsis "Module to convert Perl XS code into C code")
+    (description "The package contains the ExtUtils::ParseXS module to
+convert Perl XS code into C code, the ExtUtils::Typemaps module to
+handle Perl/XS typemap files, and their submodules.")
+    (license (package-license perl))))
+
 (define-public perl-extutils-pkgconfig
   (package
     (name "perl-extutils-pkgconfig")