summary refs log tree commit diff
path: root/gnu/packages/perl6.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-29 05:18:40 +0000
committerEfraim Flashner <efraim@flashner.co.il>2024-03-04 10:41:58 +0200
commit0e3cf25786e825471e88d87ca758c9986dcc20c2 (patch)
treeddb7c93fbd56e5ba8bb7fca46f0a5f333069b603 /gnu/packages/perl6.scm
parentf54f918b4f66d9517a64a7a5906a163ec6dbc6f0 (diff)
downloadguix-0e3cf25786e825471e88d87ca758c9986dcc20c2.tar.gz
gnu: perl6-json-name: Update to 0.0.6.
* gnu/packages/perl6.scm (perl6-json-name): Update to 0.0.6.
[source]: Reindent.
[propagated-inputs]: Add perl6-json-optin.
[synopsis, description]: Fix minor stylistic issues.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/perl6.scm')
-rw-r--r--gnu/packages/perl6.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 98631e7843..ab6e1759b0 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -464,27 +464,28 @@ of the same class using @code{JSON::Unmarshal}.")
 (define-public perl6-json-name
   (package
     (name "perl6-json-name")
-    (version "0.0.3")
+    (version "0.0.6")
     (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/jonathanstowe/JSON-Name")
-               (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "130qwdpbj5qdlsdz05y0rksd79lzbq79scy47n6lnf21b0hz1qjc"))))
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jonathanstowe/JSON-Name")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0fbwp3av4kh7zlbrmgbka4x6s3d6fsw2qxafi9hyq0y896wsaf94"))))
     (build-system rakudo-build-system)
     (arguments '(#:with-zef? #f))
+    (propagated-inputs
+     (list perl6-json-optin))
     (home-page "https://github.com/jonathanstowe/JSON-Name")
-    (synopsis "Provides a trait to store an alternative JSON Name")
+    (synopsis "Provide a trait to store an alternative JSON name")
     (description "This is released as a dependency of @code{JSON::Marshal} and
 @code{JSON::Unmarshal} in order to save duplication, it is intended to store a
 separate JSON name for an attribute where the name of the JSON attribute might be
 changed, either for aesthetic reasons or the name is not a valid Perl identifier.
 It will of course also be needed in classes thar are going to use
-@code{JSON::Marshal} or @code{JSON::Unmarshal} for serialisation/de-serialisation.")
+@code{JSON::Marshal} or @code{JSON::Unmarshal} for serialization/deserialization.")
     (license license:artistic2.0)))
 
 (define-public perl6-json-optin