summary refs log tree commit diff
path: root/gnu/packages/perl6.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-10 21:19:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-19 21:14:37 +0200
commit308faa1174c4d2f581b1a155bc65d6decaef2502 (patch)
tree3d84bc535eac85ee95552270a9000b9d08a4f092 /gnu/packages/perl6.scm
parent5f6f1f3d2532cfcf63111a0a733f411eeb7d9e3a (diff)
downloadguix-308faa1174c4d2f581b1a155bc65d6decaef2502.tar.gz
gnu: Add perl6-svg-plot.
* gnu/packages/perl6.scm (perl6-svg-plot): New variable.
Diffstat (limited to 'gnu/packages/perl6.scm')
-rw-r--r--gnu/packages/perl6.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 0db41da0c0..393b533636 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -450,6 +450,33 @@ around @code{XML::Writer}, adding only the xmlns attributes that identifies an
 XML file as SVG.")
       (license license:artistic2.0))))
 
+(define-public perl6-svg-plot
+  ;; Latest commit
+  (let ((commit "062570a78fd38c3c6baba29dfe2fbb8ca014f4de")
+        (revision "1"))
+    (package
+      (name "perl6-svg-plot")
+      (version (git-version "0.0.0" revision commit))
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                 (url "https://github.com/moritz/svg-plot")
+                 (commit commit)))
+          (file-name (git-file-name name version))
+          (sha256
+           (base32
+            "095ga5hbg92jnmczxvhk1hjz14yr334zyf8cph4w5w5frcza44my"))))
+      (build-system rakudo-build-system)
+      (propagated-inputs
+       `(("perl6-svg" ,perl6-svg)))
+      (home-page "https://github.com/moritz/svg-plot")
+      (synopsis "Perl 6 charting and plotting library that produces SVG output")
+      (description "@code{SVG::Plot} is a simple 2D chart plotter for Perl 6.
+It currently supports bars, stacked bars, lines and points (both equally spaced
+with optional labels, or xy plots).")
+      (license license:artistic2.0))))
+
 (define-public perl6-tap-harness
   (package
     (name "perl6-tap-harness")