summary refs log tree commit diff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2022-12-26 16:01:33 -0500
committerChristopher Baines <mail@cbaines.net>2023-01-16 20:22:19 +0000
commitab09e8e578480463bafd8e21451acf9dd6ddd74f (patch)
tree442cb45c9e37eb718a057e54f21272959359188f /gnu/packages/photo.scm
parenta5c422f958f5991bb0f88bd871616dcd31ab0d8d (diff)
downloadguix-ab09e8e578480463bafd8e21451acf9dd6ddd74f.tar.gz
gnu: perl-image-exiftool: Update to 12.50, use new package style.
* gnu/packages/photo.scm (perl-image-exiftool): Update to 12.50.
[arguments]: Use G-expresisons. Remove trailing #t. Use #$output instead of
assoc-ref.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm27
1 files changed, 12 insertions, 15 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 2d012b187f..d658b3d3e7 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -301,7 +301,7 @@ MTP, and much more.")
 (define-public perl-image-exiftool
   (package
     (name "perl-image-exiftool")
-    (version "12.16")
+    (version "12.50")
     (source
      (origin
        (method url-fetch)
@@ -311,24 +311,21 @@ MTP, and much more.")
              ;; New releases may take a while to hit CPAN.
              (string-append "https://www.sno.phy.queensu.ca/~phil/exiftool/"
                             "Image-ExifTool-" version ".tar.gz")))
-       (patches (search-patches "perl-image-exiftool-CVE-2021-22204.patch"))
        (sha256
         (base32
-         "0skm22b3gg1bfk0amklrprpva41m6mkrhqp0gi7z1nmcf9ypjh61"))))
+         "1a605rz00d7p866a22sw0s63m5a6y4xqqrzp7q7jyc0hbky43s5w"))))
     (build-system perl-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'post-install
-           (lambda* (#:key outputs #:allow-other-keys)
-             ;; Make sure the 'exiftool' commands finds the library.
-             ;; XXX: Shouldn't it be handled by PERL-BUILD-SYSTEM?
-             (let* ((out (assoc-ref outputs "out"))
-                    (pm  (find-files out "^ExifTool\\.pm$"))
-                    (lib (dirname (dirname (car pm)))))
-               (wrap-program (string-append out "/bin/exiftool")
-                 `("PERL5LIB" prefix (,lib)))
-               #t))))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'install 'post-install
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   ;; Make sure the 'exiftool' commands finds the library.
+                   ;; XXX: Shouldn't it be handled by PERL-BUILD-SYSTEM?
+                   (let* ((pm  (find-files #$output "^ExifTool\\.pm$"))
+                          (lib (dirname (dirname (car pm)))))
+                     (wrap-program (string-append #$output "/bin/exiftool")
+                       `("PERL5LIB" prefix (,lib)))))))))
     (home-page "https://metacpan.org/release/Image-ExifTool")
     (synopsis "Program and Perl library to manipulate EXIF and other metadata")
     (description "This package provides the @code{exiftool} command and the