summary refs log tree commit diff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-03-05 22:56:40 +0000
committerChristopher Baines <mail@cbaines.net>2021-03-06 00:18:30 +0000
commita8448da0f4a090818104e64dd79f90b0e50d5e77 (patch)
tree494c58b4724f12cd9de0db9b0a7096de2b922c0f /gnu/packages/php.scm
parent4f4b749e75b38b8c08b4f67ef51c2c8740999e28 (diff)
parenta714af38d5d1046081524d859cde4cd8fd12a923 (diff)
downloadguix-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm17
1 files changed, 13 insertions, 4 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 1c71c1f40f..e93d1122be 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016-2020 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2019 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -60,7 +60,7 @@
 (define-public php
   (package
     (name "php")
-    (version "7.4.15")
+    (version "7.4.16")
     (home-page "https://secure.php.net/")
     (source (origin
               (method url-fetch)
@@ -68,7 +68,7 @@
                                   "php-" version ".tar.xz"))
               (sha256
                (base32
-                "1f1wsi2frdbr9a3hvhmk3mmd7cwzf6mwya2akpzkwyygy1jrr1cv"))
+                "12xr7w2mk8ab3igvbpi94ks2xfw2nqga9a6nxs94rvcdz3xcw5hw"))
               (modules '((guix build utils)))
               (snippet
                '(with-directory-excursion "ext"
@@ -194,7 +194,8 @@
                                 "ext/intl/tests/timezone_getErrorCodeMessage_basic.phpt"
                                 "ext/intl/tests/timezone_getOffset_error.phpt"
                                 "sapi/cli/tests/cli_process_title_unix.phpt"
-                                "sapi/cli/tests/upload_2G.phpt")))
+                                "sapi/cli/tests/upload_2G.phpt"
+                                "Zend/tests/concat_003.phpt")))
                    '())
 
              ;; Drop tests that are known to fail.
@@ -326,6 +327,14 @@
                          ;; Expects an empty Array; gets one with " " in it.
                          "ext/pcre/tests/bug80118.phpt"))
 
+             ;; Accomodate two extra openssl errors flanking the expected one:
+             ;; random number generator:RAND_{load,write}_file:Cannot open file
+             ;; This is due to an invalid $HOME, but changing it in the test
+             ;; still prints the first one & changing it globally is overkill.
+             (substitute* "ext/openssl/tests/bug80747.phpt"
+               ((".*error:%s:key size too small.*" match)
+                (string-append "%s\n" match "%s\n")))
+
              ;; Skip tests requiring network access.
              (setenv "SKIP_ONLINE_TESTS" "1")
              ;; Without this variable, 'make test' passes regardless of failures.