summary refs log tree commit diff
path: root/gnu/packages/pkg-config.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-07-05 18:26:48 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-24 08:12:57 +0200
commit032974aae621e871c86c9654f94de9c07e2fde43 (patch)
treec9c81bd2bcb2acaa9de6b156365198993a2bb98f /gnu/packages/pkg-config.scm
parent2b9ef6e5ef13a4f17312633e514f034f7fd6f155 (diff)
downloadguix-032974aae621e871c86c9654f94de9c07e2fde43.tar.gz
gnu: pkg-config: Fix cross-compilation.
* gnu/packages/pkg-config.scm (%pkg-config)[arguments]: Add configure-flags
to disable tests that fail when cross-compiling.
Diffstat (limited to 'gnu/packages/pkg-config.scm')
-rw-r--r--gnu/packages/pkg-config.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/pkg-config.scm b/gnu/packages/pkg-config.scm
index 6fc19a975d..329a63658a 100644
--- a/gnu/packages/pkg-config.scm
+++ b/gnu/packages/pkg-config.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012, 2013, 2014, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -48,7 +49,17 @@
              (base32
               "14fmwzki1rlz8bs2p810lk6jqdxsk966d8drgsjmi54cd00rrikg"))))
    (build-system gnu-build-system)
-   (arguments `(#:configure-flags '("--with-internal-glib")))
+   (arguments
+    `(#:configure-flags
+      '("--with-internal-glib"
+        ;; Those variables are guessed incorrectly when cross-compiling.
+        ;; See: https://developer.gimp.org/api/2.0/glib/glib-cross-compiling.html.
+        ,@(if (%current-target-system)
+              '("glib_cv_stack_grows=no"
+                "glib_cv_uscore=no"
+                "ac_cv_func_posix_getpwuid_r=yes"
+                "ac_cv_func_posix_getgrgid_r=yes")
+              '()))))
    (native-search-paths
     (list (search-path-specification
            (variable "PKG_CONFIG_PATH")