summary refs log tree commit diff
path: root/gnu/packages/polkit.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-06-08 10:43:10 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-08 23:28:04 +0200
commit9178566954cc7f34d2d991d31df4565adad93508 (patch)
treea800e51bb930502ac39437ae795882cfcae3e98b /gnu/packages/polkit.scm
parent7ccf416dd00b9842d7f9801ae8d2438e92a4cdfe (diff)
downloadguix-9178566954cc7f34d2d991d31df4565adad93508.tar.gz
gnu: polkit: Add replacement for CVE-2021-3560.
* gnu/packages/patches/polkit-CVE-2021-3560.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/polkit.scm (polkit/fixed): New variable.
(polkit)[replacement]: New field.
Diffstat (limited to 'gnu/packages/polkit.scm')
-rw-r--r--gnu/packages/polkit.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index d868aceec2..40aa523b23 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -44,6 +44,7 @@
   (package
     (name "polkit")
     (version "0.116")
+    (replacement polkit/fixed)
     (source (origin
              (method url-fetch)
              (uri (string-append
@@ -135,6 +136,13 @@ making process with respect to granting access to privileged operations
 for unprivileged applications.")
     (license lgpl2.0+)))
 
+(define polkit/fixed
+  (package
+    (inherit polkit)
+    (source (origin
+              (inherit (package-source polkit))
+              (patches (search-patches "polkit-CVE-2021-3560.patch"))))))
+
 (define-public polkit-qt
   (package
     (name "polkit-qt")