summary refs log tree commit diff
path: root/gnu/packages/popt.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-02-11 23:04:18 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-12 00:14:32 +0100
commitdf77a46273cf6d94f8d6264efdbfdba66ea6be13 (patch)
treef55f5b9bdc68d7243223a5eca521d45786519f16 /gnu/packages/popt.scm
parentbeacfcabe735b6d8d07a682f1c0663e4670cea5b (diff)
downloadguix-df77a46273cf6d94f8d6264efdbfdba66ea6be13.tar.gz
gnu: Add popt.
* gnu/packages/popt.scm (popt): New file.
* Makefile.am (MODULES): Add it.
Diffstat (limited to 'gnu/packages/popt.scm')
-rw-r--r--gnu/packages/popt.scm61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnu/packages/popt.scm b/gnu/packages/popt.scm
new file mode 100644
index 0000000000..e822b5c795
--- /dev/null
+++ b/gnu/packages/popt.scm
@@ -0,0 +1,61 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages popt)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix licenses))
+
+(define-public popt
+  (package
+    (name "popt")
+    (version "1.16")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "http://rpm5.org/files/popt/popt-"
+                                 version ".tar.gz"))
+             (sha256
+              (base32
+               "1j2c61nn2n351nhj4d25mnf3vpiddcykq005w2h6kw79dwlysa77"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases (alist-cons-before
+                 'configure 'patch-test
+                 (lambda _
+                   (substitute* "test-poptrc.in"
+                     (("/bin/echo") (which "echo")))
+                   (substitute* "testit.sh"   ; don't expect old libtool names
+                     (("lt-test1") "test1")))
+                 %standard-phases)))
+    (home-page #f)
+    (synopsis "Command line option parsing library")
+    (description
+     "This is the popt(3) command line option parsing library.  While it is
+similar to getopt(3), it contains a number of enhancements, including:
+
+  - popt is fully reentrant;
+
+  - popt can parse arbitrary argv[] style arrays while getopt(3) makes this
+    quite difficult;
+
+  - popt allows users to alias command line arguments;
+
+  - popt provides convience functions for parsing strings into argv[] style
+    arrays.")
+    (license x11)))