summary refs log tree commit diff
path: root/gnu/packages/pretty-print.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-30 07:15:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-30 07:44:29 +0300
commitd01f680c07294b4b8e981ac78da5b551951175bc (patch)
treebc0944fcbfae4f546d29d2725110f3a5dfa022f2 /gnu/packages/pretty-print.scm
parent6447e19108c69277ff2ead3fb084b04cd516e76a (diff)
downloadguix-d01f680c07294b4b8e981ac78da5b551951175bc.tar.gz
gnu: a2ps: Use 'modify-phases'.
* gnu/packages/pretty-print.scm (a2ps)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/pretty-print.scm')
-rw-r--r--gnu/packages/pretty-print.scm61
1 files changed, 30 insertions, 31 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 1662126d53..8ba9780685 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -58,37 +58,36 @@
      `(("gperf" ,gperf)
        ("perl" ,perl)))
     (arguments
-     '(#:phases (alist-cons-before
-                 'build 'patch-scripts
-                 (lambda _
-                   (substitute*
-                       '("afm/make_fonts_map.sh"
-                         "tests/defs"
-                         "tests/backup.tst"
-                         "tests/styles.tst")
-                     (("/bin/rm") (which "rm"))))
-                 (alist-cons-before
-                  'check 'patch-test-files
-                  ;; Alternatively, we could unpatch the shebangs in tstfiles
-                  (lambda* (#:key inputs #:allow-other-keys)
-                    (let ((perl (assoc-ref inputs "perl")))
-                      (substitute* '("tests/ps-ref/includeres.ps"
-                                     "tests/gps-ref/includeres.ps")
-                        (("/usr/local/bin/perl")
-                         (string-append perl "/bin/perl"))))
-                    ;; Some of the reference postscript contain a 'version 3'
-                    ;; string that in inconsistent with the source text in the
-                    ;; tstfiles directory.  Erroneous search-and-replace?
-                    (substitute* '("tests/ps-ref/InsertBlock.ps"
-                                   "tests/gps-ref/InsertBlock.ps"
-                                   "tests/ps-ref/bookie.ps"
-                                   "tests/gps-ref/bookie.ps")
-                      (("version 3") "version 2"))
-                    (substitute* '("tests/ps-ref/psmandup.ps"
-                                   "tests/gps-ref/psmandup.ps")
-                      (("#! */bin/sh") (string-append
-                                        "#!" (which "sh")))))
-                  %standard-phases))))
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'patch-scripts
+           (lambda _
+             (substitute*
+                 '("afm/make_fonts_map.sh"
+                   "tests/defs"
+                   "tests/backup.tst"
+                   "tests/styles.tst")
+               (("/bin/rm") (which "rm")))))
+         (add-before 'check 'patch-test-files
+           ;; Alternatively, we could unpatch the shebangs in tstfiles
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((perl (assoc-ref inputs "perl")))
+               (substitute* '("tests/ps-ref/includeres.ps"
+                              "tests/gps-ref/includeres.ps")
+                 (("/usr/local/bin/perl")
+                  (string-append perl "/bin/perl"))))
+             ;; Some of the reference postscript contain a 'version 3'
+             ;; string that in inconsistent with the source text in the
+             ;; tstfiles directory.  Erroneous search-and-replace?
+             (substitute* '("tests/ps-ref/InsertBlock.ps"
+                            "tests/gps-ref/InsertBlock.ps"
+                            "tests/ps-ref/bookie.ps"
+                            "tests/gps-ref/bookie.ps")
+               (("version 3") "version 2"))
+             (substitute* '("tests/ps-ref/psmandup.ps"
+                            "tests/gps-ref/psmandup.ps")
+               (("#! */bin/sh") (string-append
+                                 "#!" (which "sh")))))))))
     (home-page "http://www.gnu.org/software/a2ps")
     (synopsis "Any file to PostScript, including pretty-printing")
     (description