summary refs log tree commit diff
path: root/gnu/packages/pretty-print.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-03-05 10:34:21 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-03-06 10:15:19 +0100
commit744f445c920f60e9080f42866c802184a1503a80 (patch)
treebcd39f3b2b4ec6c6e84f9971f0204236a8e4e0f3 /gnu/packages/pretty-print.scm
parentfecd32501ffcbb7bebe7b125e29d1c1865de08da (diff)
downloadguix-744f445c920f60e9080f42866c802184a1503a80.tar.gz
gnu: fmt: Use HTTPS and git-fetch.
* gnu/packages/pretty-print.scm (fmt)[source]: Use git-fetch.
[home-page]: Use HTTPS.
Diffstat (limited to 'gnu/packages/pretty-print.scm')
-rw-r--r--gnu/packages/pretty-print.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index e6560696f5..b9dce8f1a6 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -25,6 +25,7 @@
 (define-module (gnu packages pretty-print)
   #:use-module (guix packages)
   #:use-module (guix licenses)
+  #:use-module (guix git-download)
   #:use-module (guix download)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
@@ -168,19 +169,20 @@ different programming languages.")
     (name "fmt")
     (version "6.0.0")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/fmtlib/fmt/releases/download/"
-                    version "/fmt-" version ".zip"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/fmtlib/fmt")
+                    (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "0h148anbaqgch6n69pxsvs1c9wmykgd052wmzgdia7qpz8w6p8dl"))))
+                "0yfrw6by4h27k3psv9x1q7z2kdbz7pkwxidr494bpa6ppglij6ba"))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
     (native-inputs
      `(("unzip" ,unzip)))
-    (home-page "http://fmtlib.net/")
+    (home-page "https://fmtlib.net/")
     (synopsis "Small and fast C++ formatting library")
     (description
      "@code{fmt} (formerly @code{cppformat}) is a formatting library for C++.