summary refs log tree commit diff
path: root/gnu/packages/printers.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-04-02 22:03:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-04-02 22:04:08 +0200
commit44e06f9cf39e50f91ba61f3e66981b8d10ad545c (patch)
treede065780dec85ab6e71fb342dff58574b81a6103 /gnu/packages/printers.scm
parent932d6e276bfde4c85d4803b396397ce618a6a61a (diff)
downloadguix-44e06f9cf39e50f91ba61f3e66981b8d10ad545c.tar.gz
gnu: Add brlaser.
* gnu/packages/printers.scm (brlaser): New variable.
Diffstat (limited to 'gnu/packages/printers.scm')
-rw-r--r--gnu/packages/printers.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/printers.scm b/gnu/packages/printers.scm
index dff9ed3010..2d608bf3cb 100644
--- a/gnu/packages/printers.scm
+++ b/gnu/packages/printers.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -20,9 +21,13 @@
 (define-module (gnu packages printers)
   #:use-module (guix packages)
   #:use-module (guix git-download)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages cups)
   #:use-module (gnu packages libusb)
+  #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages qt))
 
@@ -68,3 +73,54 @@
 with Graphtec and Sihouette plotting cutters using an SVG file as its input.")
     (home-page "http://robocut.org")
     (license license:gpl3+)))
+
+(define-public brlaser
+  (let ((commit "779f71e80fcc583f4537c844de141cf8e6a738fe")
+        (revision "1"))
+    (package
+      (name "brlaser")
+      (version (git-version "4" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/pdewacht/brlaser.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0yrz9706660hdfi2y0ndp254r0vw9y665hwmxbbzfnz4ai13vj50"))))
+      (build-system cmake-build-system)
+      (arguments
+       `(#:configure-flags
+         (list (string-append "-DCUPS_DATA_DIR="
+                              (assoc-ref %outputs "out")
+                              "/share/cups")
+               (string-append "-DCUPS_SERVER_BIN="
+                              (assoc-ref %outputs "out")
+                              "/lib/cups"))))
+      (inputs
+       `(("ghostscript" ,ghostscript)
+         ("cups" ,cups)
+         ("zlib" ,zlib)))
+      (home-page "https://github.com/pdewacht/brlaser")
+      (synopsis "Brother laser printer driver")
+      (description "Brlaser is a CUPS driver for Brother laser printers.  This
+driver is known to work with these printers:
+
+@enumerate
+@item Brother DCP-1510
+@item Brother DCP-7030
+@item Brother DCP-7040
+@item Brother DCP-7055
+@item Brother DCP-7055W
+@item Brother DCP-7065DN
+@item Brother DCP-7080
+@item Brother HL-1200 series
+@item Brother HL-L2320D series
+@item Brother HL-L2360D series
+@item Brother MFC-7240
+@item Brother MFC-7360N
+@end enumerate
+
+It partially works with printers from the Brother HL-L2300D series.")
+      (license license:gpl2+))))