summary refs log tree commit diff
path: root/gnu/packages/profiling.scm
diff options
context:
space:
mode:
authorDave Love <fx@gnu.org>2017-10-02 21:48:44 +0100
committerLudovic Courtès <ludo@gnu.org>2017-10-03 17:07:55 +0200
commita6121c0a3e75013a463d8e81c8e9fb999650e01b (patch)
tree0bc2a7e091a376fd9e51445ccb3264d20d0494f1 /gnu/packages/profiling.scm
parent6a3af24f062350751ab70ba21bdcf8792b6624d6 (diff)
downloadguix-a6121c0a3e75013a463d8e81c8e9fb999650e01b.tar.gz
gnu: Add otf2.
* gnu/packages/profiling.scm (otf2): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/profiling.scm')
-rw-r--r--gnu/packages/profiling.scm37
1 files changed, 36 insertions, 1 deletions
diff --git a/gnu/packages/profiling.scm b/gnu/packages/profiling.scm
index 6d62aa2609..7c0ab6e95e 100644
--- a/gnu/packages/profiling.scm
+++ b/gnu/packages/profiling.scm
@@ -29,7 +29,8 @@
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages libunwind)
   #:use-module (gnu packages linux)
-  #:use-module (gnu packages ncurses))
+  #:use-module (gnu packages ncurses)
+  #:use-module (gnu packages python))
 
 ;; Fixme: Separate out lib and fix resulting cycle errors; separate libpfm
 ;; output(?); build libmsr and add that component.
@@ -124,3 +125,37 @@ performance measurement opportunites across the hardware and software stack.")
                    ;; "BSD-like": src/libpfm-3.y/*, src/libpfm4/*
                    ;; lgpl2.1+: src/perfctr-2.*/*
                    ))))
+
+;; NB. there's a potential name clash with libotf.
+(define-public otf2
+  (package
+    (name "otf2")
+    (version "2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://www.vi-hps.org/upload/packages/otf2/otf2-"
+                           version ".tar.gz"))
+       (sha256 (base32 "1lyaqhdfaqm1kd23yk71g71vkscw83s7m57j017y768h8sh8xlwa"))))
+    (native-inputs `(("python" ,python)))
+    (outputs '("doc"                              ; 18MB
+               "lib"
+               "out"))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags '("--enable-shared" "--disable-static")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'licence
+           (lambda* (#:key outputs #:allow-other-keys)
+             (for-each (lambda (output)
+                         (let ((doc (string-append (assoc-ref outputs output)
+                                                   "/share/doc/otf2")))
+                           (install-file "COPYING" doc)))
+                       '("lib" "doc"))
+             #t)))))
+    (home-page "http://www.vi-hps.org/projects/score-p/")
+    (synopsis "Open Trace Format 2 library")
+    (description "The Open Trace Format 2 (OTF2) is a scalable, memory
+efficient event trace data format plus support library.")
+    (license license:bsd-3)))