summary refs log tree commit diff
path: root/gnu/packages/prolog.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-01-03 19:53:04 -0600
committerBrett Gilio <brettg@gnu.org>2020-01-03 19:53:04 -0600
commitd98e64b4e5b46a67b582df5032647bb169427d6d (patch)
treebd9521d0e1ce6a1b2f467f71e8d2efc59510fe8c /gnu/packages/prolog.scm
parent1074ec1dd7c718e5a66e6e555248c3a1c271d46f (diff)
downloadguix-d98e64b4e5b46a67b582df5032647bb169427d6d.tar.gz
gnu: Rename module gprolog to prolog.
* gnu/local.mk (GNU_SYSTEM_MODULES): Replace gprolog.scm => prolog.scm.
* gnu/packages/{gprolog.scm -> prolog.scm}: Rename file so it is not
  implementation specific.
Diffstat (limited to 'gnu/packages/prolog.scm')
-rw-r--r--gnu/packages/prolog.scm69
1 files changed, 69 insertions, 0 deletions
diff --git a/gnu/packages/prolog.scm b/gnu/packages/prolog.scm
new file mode 100644
index 0000000000..7c344988d5
--- /dev/null
+++ b/gnu/packages/prolog.scm
@@ -0,0 +1,69 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2013 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages prolog)
+  #:use-module (guix download)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (guix build-system gnu)
+  #:use-module (srfi srfi-1))
+
+(define-public gprolog
+  (package
+    (name "gprolog")
+    (version "1.4.5")
+    (source
+      (origin
+        (method url-fetch)
+        ;; Recent versions are not hosted on the GNU mirrors.
+        (uri (list (string-append "http://gprolog.org/gprolog-" version
+                                  ".tar.gz")
+                   (string-append "mirror://gnu/gprolog/gprolog-" version
+                                  ".tar.gz")))
+        (sha256
+         (base32
+          "0z4cc42n3k6i35b8mr816iwsvrpxshw6d7dgz6s2h1hy0l7g1p5z"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       (list (string-append
+              "--with-install-dir=" %output "/share/gprolog"))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'change-dir-n-fix-shells
+           (lambda _
+             (chdir "src")
+             (substitute* "configure"
+               (("-/bin/sh")  (string-append "-"  (which "sh")))
+               (("= /bin/sh") (string-append "= " (which "sh"))))
+             #t)))))
+    (home-page "https://www.gnu.org/software/gprolog/")
+    (synopsis "Prolog compiler")
+    (description
+     "GNU Prolog is a standards-compliant Prolog compiler with constraint
+solving over finite domains.  It accepts Prolog+ constraint programs and
+produces a compiled, native binary which can function in a stand-alone
+manner.  It also features an interactive interpreter.")
+    (license (list gpl2+ lgpl3+))
+
+    ;; See 'configure' for the list of supported architectures.
+    (supported-systems (fold delete
+                             %supported-systems
+                             '("armhf-linux" "mips64el-linux")))))