summary refs log tree commit diff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-11-26 16:41:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-15 17:27:34 +0100
commitc22c803efcb126d828dc3ab75ed23c23b2fd22f7 (patch)
tree4cf2f95d8743142a8036977fae13943c5cd7fb01 /gnu/packages/protobuf.scm
parente2931e99790aae39ec27f0f2e2d9ac3db5f63f5d (diff)
downloadguix-c22c803efcb126d828dc3ab75ed23c23b2fd22f7.tar.gz
gnu: Add protobuf-next.
* gnu/packages/protobuf.scm (protobuf-next): New variable.
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 52b1337b4d..028b2f21e1 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -109,6 +109,19 @@ yet extensible format.  Google uses Protocol Buffers for almost all of its
 internal RPC protocols and file formats.")
     (license license:bsd-3)))
 
+(define-public protobuf-next
+  (package (inherit protobuf)
+    (name "protobuf")
+    (version "3.6.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/google/protobuf/releases/"
+                                  "download/v" version "/protobuf-cpp-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0a955bz59ihrb5wg7dwi12xajdi5pmz4bl0g147rbdwv393jwwxk"))))))
+
 ;; XXX Remove this old version when no other packages depend on it.
 (define-public protobuf-2
   (package (inherit protobuf)