summary refs log tree commit diff
path: root/gnu/packages/pth.scm
diff options
context:
space:
mode:
authorThiago Jung Bauermann <bauermann@kolabnow.com>2021-08-17 01:55:52 -0300
committerMathieu Othacehe <othacehe@gnu.org>2021-08-19 17:00:49 +0200
commit6b85b4cf9bacb9dc3ed139df21281f81a50296b6 (patch)
treedfe14f123f007e57874bd9f4f68b1a99b2711817 /gnu/packages/pth.scm
parentc88a870e9c13c54adafc69855df2d00ed200782f (diff)
downloadguix-6b85b4cf9bacb9dc3ed139df21281f81a50296b6.tar.gz
gnu: pth: Update ‘config.guess’ and ‘config.sub’
The original versions are too old to recognize architectures such as
aarch64 and powerpc64le.

* gnu/packages/pth.scm (pth)[arguments]: Change from quasiquote to quote.
[#:phases]{update-config-scripts}: New.
[native-inputs]: Add ‘config’.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/pth.scm')
-rw-r--r--gnu/packages/pth.scm22
1 files changed, 16 insertions, 6 deletions
diff --git a/gnu/packages/pth.scm b/gnu/packages/pth.scm
index 1908ce7763..8efede068c 100644
--- a/gnu/packages/pth.scm
+++ b/gnu/packages/pth.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2012, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021 Thiago Jung Bauermann <bauermann@kolabnow.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -19,6 +20,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages pth)
+  #:use-module (gnu packages autotools)
   #:use-module (guix licenses)
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -38,12 +40,20 @@
         "0ckjqw5kz5m30srqi87idj7xhpw6bpki43mj07bazjm2qmh3cdbj"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:parallel-build? #f
-       #:configure-flags (list 
-                           ,@(if (string=? "aarch64-linux"
-                                           (%current-system))
-                               '("--host=aarch64-unknown-linux-gnu")
-                               '()))))
+     '(#:parallel-build? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'update-config-scripts
+           (lambda* (#:key inputs native-inputs #:allow-other-keys)
+             ;; Replace outdated config.guess and config.sub.
+             (for-each (lambda (file)
+                         (install-file
+                          (search-input-file
+                           (or native-inputs inputs)
+                           (string-append "/bin/" file)) "."))
+                       '("config.guess" "config.sub")))))))
+    (native-inputs
+     (list config))
     (home-page "https://www.gnu.org/software/pth/")
     (synopsis "Portable thread library")
     (description