summary refs log tree commit diff
path: root/gnu/packages/pulseaudio.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-15 14:38:00 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-17 14:39:26 +0200
commit7136f3e64f3b41b4ee8b54f79402da3edbcfc1ca (patch)
treee7e1fbfeeecc8c683076df7f45b4139bdea36ebd /gnu/packages/pulseaudio.scm
parentd5e60a2a9322d336affe1f07e483b4175ee82cd8 (diff)
downloadguix-7136f3e64f3b41b4ee8b54f79402da3edbcfc1ca.tar.gz
gnu: pulseaudio: Adjust inputs.
* gnu/packages/pulseaudio.scm (pulseaudio)[inputs]: Remove obsolete
LIBSAMPLERATE. Replace SPEEX with SPEEXDSP.  Move CHECK, INTLTOOL and M4 ...
[native-inputs]: ... here.
Diffstat (limited to 'gnu/packages/pulseaudio.scm')
-rw-r--r--gnu/packages/pulseaudio.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 428d0467a3..f7196d624e 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -168,22 +168,21 @@ rates.")
      `(("alsa-lib" ,alsa-lib)
        ("bluez" ,bluez)
        ("sbc" ,sbc)
-       ("speex" ,speex)
+       ("speexdsp" ,speexdsp)
        ("libsndfile" ,libsndfile)
-       ("libsamplerate" ,libsamplerate)
        ("jack" ,jack-1) ; For routing the output to jack.
        ("dbus" ,dbus)
        ("glib" ,glib)
-       ("intltool" ,intltool)
-       ("m4" ,m4)
        ("libltdl" ,libltdl)
        ("fftwf" ,fftwf)
        ("avahi" ,avahi)
-       ("eudev" ,eudev)           ;for the detection of hardware audio devices
-       ("check" ,check)))
+       ("eudev" ,eudev)))         ;for the detection of hardware audio devices
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("glib:bin" ,glib "bin")))
+     `(("check" ,check)
+       ("glib:bin" ,glib "bin")
+       ("intltool" ,intltool)
+       ("m4" ,m4)
+       ("pkg-config" ,pkg-config)))
     (propagated-inputs
      ;; 'libpulse*.la' contain `-lgdbm' and `-lcap', so propagate them.
      `(("libcap" ,libcap)