summary refs log tree commit diff
path: root/gnu/packages/python-build.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-15 22:44:33 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:12 -0400
commit21d6985a8b3c6e53aab648275dc27b72c7453437 (patch)
treeda75b242cf2d1d29ea6e365a662ce6d4199c69ea /gnu/packages/python-build.scm
parent51b1a70b7114183985ea4c736c83894a797e1039 (diff)
downloadguix-21d6985a8b3c6e53aab648275dc27b72c7453437.tar.gz
gnu: python-poetry-core: Update to 1.5.2.
* gnu/packages/python-build.scm (python-poetry-core): Update to 1.5.2.
[source]: Adjust URL.
[build-system]: Use pyproject-build-system.
[arguments]: New field.
Diffstat (limited to 'gnu/packages/python-build.scm')
-rw-r--r--gnu/packages/python-build.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 1e60c5ab38..d87f3034ef 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -454,14 +454,22 @@ order to make bootstrapping easier.")
 (define-public python-poetry-core
   (package
     (name "python-poetry-core")
-    (version "1.0.7")
+    (version "1.5.2")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "poetry-core" version))
+       (uri (pypi-uri "poetry_core" version))
        (sha256
-        (base32 "01n2rbsvks7snrq3m1d08r3xz9q2715ajb62fdb6rvqnb9sirhcq"))))
-    (build-system python-build-system)
+        (base32 "053c8dw632p7jkhjb51k0wcx6hdw4r3lk97mds76df653qxnqmf6"))))
+    (build-system pyproject-build-system)
+    (arguments
+     `(#:tests? #f                      ;disabled to avoid extra dependencies
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'add-self-to-path
+           (lambda _
+             ;; The build system requires itself.
+             (setenv "PYTHONPATH" "src"))))))
     (home-page "https://github.com/python-poetry/poetry-core")
     (synopsis "Poetry PEP 517 build back-end")
     (description