summary refs log tree commit diff
path: root/gnu/packages/python-build.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-15 07:57:03 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-27 08:05:52 -0500
commit3ab7e15cc5802251d3a668d6eed9a12eb6befdb3 (patch)
tree5c1f69ee1edd72bcd105129e754ae1e619798114 /gnu/packages/python-build.scm
parentdbcd2050500c932190d710cee43f5e14f0fd59db (diff)
downloadguix-3ab7e15cc5802251d3a668d6eed9a12eb6befdb3.tar.gz
gnu: Add python-pypa-build.
* gnu/packages/python-build.scm (python-pypa-build): New variable.
Diffstat (limited to 'gnu/packages/python-build.scm')
-rw-r--r--gnu/packages/python-build.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index b0940b67f3..65b90ddf40 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
-;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -113,6 +113,32 @@ Language (TOML) configuration files.")
       "Wrappers to build Python packages using PEP 517 hooks.")
      (license license:expat))))
 
+;;; The name 'python-pypa-build' is chosen rather than 'python-build' to avoid
+;;; a name clash with python-build from (guix build-system python).
+(define-public python-pypa-build
+  (package
+    (name "python-pypa-build")
+    (version "0.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "build" version))
+              (sha256
+               (base32
+                "1d6m21lijwm04g50nwgsgj7x3vhblzw7jv05ah8psqgzk20bbch8"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))                    ;to tests in the PyPI release
+    (propagated-inputs
+     `(("python-pep517", python-pep517-bootstrap)
+       ("python-toml" ,python-toml)))
+    (home-page "https://pypa-build.readthedocs.io/en/latest/")
+    (synopsis "Simple Python PEP 517 package builder")
+    (description "The @command{build} command invokes the PEP 517 hooks to
+build a distribution package.  It is a simple build tool and does not perform
+any dependency management.  It aims to keep dependencies to a minimum, in
+order to make bootstrapping easier.")
+    (license license:expat)))
+
 (define-public python-poetry-core
   (package
     (name "python-poetry-core")