summary refs log tree commit diff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-01 09:54:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-01 10:24:36 -0400
commit1aa7f017e84491c83e4e90121a31ece6383abe2b (patch)
treeb3c4a76ef43c9621afc18ab3c212519bf1e954d7 /gnu/packages/python-check.scm
parent8579304e8f4deaca33b816b2d56af1d814a03bde (diff)
downloadguix-1aa7f017e84491c83e4e90121a31ece6383abe2b.tar.gz
gnu: Add python-pytest-exploratory.
* gnu/packages/python-check.scm (python-pytest-exploratory): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index d5ebb918b8..8252f02182 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -418,6 +418,35 @@ are too large to conveniently hard-code them in the tests.")
 advanced doctest support and enables the testing of reStructuredText files.")
     (license license:bsd-3)))
 
+(define-public python-pytest-exploratory
+  (package
+    (name "python-pytest-exploratory")
+    (version "0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest_exploratory" version))
+       (sha256
+        (base32 "159rcqv6wrdqdlag1gz39n6fk58232hbxshan043ljgpp1qfs6xk"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest" "tests")))))))
+    (propagated-inputs
+     `(("python-ipython" ,python-ipython)
+       ("python-py" ,python-py)
+       ("python-pytest" ,python-pytest)))
+    (native-inputs `(("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/nokia/pytest-exploratory")
+    (synopsis "Interactive console for Pytest")
+    (description "This Pytest plugin provides an IPython extension that allows
+for interactively selecting and running Pytest tests.")
+    (license license:expat)))
+
 (define-public python-pytest-filter-subpackage
   (package
     (name "python-pytest-filter-subpackage")