summary refs log tree commit diff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-15 13:31:17 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-15 13:32:05 +0300
commit1e631e46698289a7182b79e106507ad749f9ee55 (patch)
tree85856ee4ee85994079b6ef7841a01047015f94ce /gnu/packages/python-check.scm
parent68845693a472bed4bc3142d8badbe577158613bd (diff)
downloadguix-1e631e46698289a7182b79e106507ad749f9ee55.tar.gz
gnu: python-pytest-trio: Honor #:tests? flag.
* gnu/packages/python-check.scm (python-pytest-trio)[arguments]: Honor
the #:tests? flag.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index fd9e0bece9..40c4b91b71 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -780,16 +780,17 @@ simpler.")
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (add-installed-pythonpath inputs outputs)
-             (invoke "pytest" "-W" "error" "-ra" "-v" "--pyargs"
-                     "pytest_trio" "--verbose" "--cov" "-k"
-                     (string-append
-                       ;; Needs network
-                       "not test_async_yield_fixture_with_nursery"
-                       " and not test_try"
-                       ;; No keyboard interrupt in our build environment.
-                       " and not test_actual_test")))))))
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "pytest" "-W" "error" "-ra" "-v" "--pyargs"
+                       "pytest_trio" "--verbose" "--cov" "-k"
+                       (string-append
+                         ;; Needs network
+                         "not test_async_yield_fixture_with_nursery"
+                         " and not test_try"
+                         ;; No keyboard interrupt in our build environment.
+                         " and not test_actual_test"))))))))
     (native-inputs
      `(("python-hypothesis" ,python-hypothesis)
        ("python-pytest" ,python-pytest)