summary refs log tree commit diff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-15 22:13:53 +0200
committerMarius Bakke <marius@gnu.org>2022-08-16 00:43:43 +0200
commit7e0116740b8d93ccd0d6d760dc89cbdc65598119 (patch)
tree33fb20c709df18158ce0b9213d022cd20a0295d3 /gnu/packages/python-check.scm
parent1e969dafb7d004ae3405cc2de3669e1c97000ce0 (diff)
downloadguix-7e0116740b8d93ccd0d6d760dc89cbdc65598119.tar.gz
gnu: python-mypy: Update to 0.971.
* gnu/packages/patches/python-mypy-12332.patch,
gnu/packages/patches/python-mypy-use-sys-path.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/python-check.scm (python-mypy): Update to 0.971.
[source](patches): Remove.
[arguments]: Skip one test.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index e196f2eccb..7cc266fbce 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1771,7 +1771,7 @@ supported by the MyPy typechecker.")
 (define-public python-mypy
   (package
     (name "python-mypy")
-    (version "0.942")
+    (version "0.971")
     (source
      (origin
        ;; Because of https://github.com/python/mypy/issues/9584, the
@@ -1788,10 +1788,7 @@ supported by the MyPy typechecker.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0hxnrqhvskiclwfj2s4gyfclzjas1dvpfxhyng8v7mq38rqps1j5"))
-       (patches
-        (search-patches "python-mypy-12332.patch"
-                        "python-mypy-use-sys-path.patch"))))
+         "0i8swdynms1wpiprgqn24za6mx8rlgxr2jash3cb5xi8jyf58n97"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -1799,7 +1796,10 @@ supported by the MyPy typechecker.")
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (invoke "pytest" "mypyc")))))))
+               (invoke "pytest" "-vv" "mypyc"
+                       ;; XXX: This test gets an unexpected DeprecationWarning
+                       ;; from recent versions of setuptools.  Ignore for now.
+                       "-k" "not testImports")))))))
     (native-inputs
      (list python-attrs
            python-lxml