summary refs log tree commit diff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-07-31 12:59:21 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-01 08:53:10 +0200
commit6364610174423b8c5a7d227bb274e799e3b965ef (patch)
tree4c5968854b095fbe593a0f82218f41ebec4cb80c /gnu/packages/python-check.scm
parenta0a55309a7aaffecb1dcfadc5daba5e7c7d896e1 (diff)
downloadguix-6364610174423b8c5a7d227bb274e799e3b965ef.tar.gz
gnu: Add python-pytest-ordering.
* gnu/packages/python-check.scm (python-pytest-ordering): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 51b864957f..7a84fe39f9 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -128,6 +128,40 @@ detect the absence of a cassette file and once again record all HTTP
 interactions, which will update them to correspond to the new API.")
     (license license:expat)))
 
+(define-public python-pytest-ordering
+  (package
+    (name "python-pytest-ordering")
+    (version "0.6")
+    (source
+     (origin
+       ;; No tests in the PyPI tarball.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ftobia/pytest-ordering")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "14msj5gyqza0gk3x7h1ivmjrwza82v84cj7jx3ks0fw9lpin7pjq"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (add-installed-pythonpath inputs outputs)
+             (invoke "pytest" "-vv" "-k"
+                     ;; This test fails because of a type mismatch of an
+                     ;; argument passed to @code{pytest.main}.
+                     "not test_run_marker_registered"))))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/ftobia/pytest-ordering")
+    (synopsis "Pytest plugin to run your tests in a specific order")
+    (description
+     "This plugin defines Pytest markers to ensure that some tests, or groups
+of tests run in a specific order.")
+    (license license:expat)))
+
 (define-public python-pytest-arraydiff
   (package
     (name "python-pytest-arraydiff")