summary refs log tree commit diff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-24 05:47:31 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-26 21:41:59 +0100
commit8923e7de0af03467744b2727780999d231f58886 (patch)
treee28a6f19c10dae640c01d09ef41958916f45cd41 /gnu/packages/python-check.scm
parentb5f990da9ca267de6685f4b95de2b9211e2d2638 (diff)
downloadguix-8923e7de0af03467744b2727780999d231f58886.tar.gz
gnu: python-pytest-doctestplus: Honor #:tests?.
* gnu/packages/python-check.scm (python-pytest-doctestplus): Honor #:tests? in
the custom 'check phase.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index a745e735db..50e63cb734 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -414,17 +414,18 @@ are too large to conveniently hard-code them in the tests.")
      '(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
              ;; Make the installed plugin discoverable by Pytest.
-             (add-installed-pythonpath inputs outputs)
-             (invoke "python" "-m" "pytest" "-k"
-                     (string-append ; skip tests that require remote data
-                      "not test_remote_data_url"
-                      " and not test_remote_data_float_cmp"
-                      " and not test_remote_data_ignore_whitespace"
-                      " and not test_remote_data_ellipsis"
-                      " and not test_remote_data_requires"
-                      " and not test_remote_data_ignore_warnings")))))))
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "-m" "pytest" "-k"
+                       (string-append   ; skip tests that require remote data
+                        "not test_remote_data_url"
+                        " and not test_remote_data_float_cmp"
+                        " and not test_remote_data_ignore_whitespace"
+                        " and not test_remote_data_ellipsis"
+                        " and not test_remote_data_requires"
+                        " and not test_remote_data_ignore_warnings"))))))))
     (native-inputs
      (list python-pytest python-setuptools-scm))
     (home-page "https://github.com/astropy/pytest-doctestplus")