summary refs log tree commit diff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-04-28 14:28:02 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-05-02 07:45:26 -0400
commit6d7e1bdb03c3b34b306ff02cfb1fe327a56644b2 (patch)
treed7234941b0c9be314d88219eaab6ca777f60062a /gnu/packages/python-check.scm
parent12ca316b83bf4a303fa9c68830fddba00e5be4f4 (diff)
downloadguix-6d7e1bdb03c3b34b306ff02cfb1fe327a56644b2.tar.gz
gnu: Add python-pytest-click.
* gnu/packages/python-check.scm (python-pytest-click): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index b68f23a220..01922b0d9d 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -46,6 +46,27 @@
   #:use-module (guix download)
   #:use-module (guix build-system python))
 
+(define-public python-pytest-click
+  (package
+    (name "python-pytest-click")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (pypi-uri "pytest_click" version))
+       (sha256
+        (base32 "1rcv4m850rl7djzdgzz2zhjd8g5ih8w6l0sj2f9hsynymlsq82xl"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-click" ,python-click)
+       ("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/Stranger6667/pytest-click")
+    (synopsis "Py.test plugin for Click")
+    (description "This package provides a plugin to test Python click
+interfaces with pytest.")
+    (license license:expat)))
+
 (define-public python-testfixtures
   (package
     (name "python-testfixtures")